OSG and picoFlamingo Runing in the OMAP Zoom2

Hiya!

Finally we've some time to start working with the OMAP Zoom 2 and you can check the results in this video.

In the video you can see our modification of OpenScenegraph and then picoFlamingo running in the OMAP ZoomII MDP. Yes, once again the "Pink Egg" presentation... we need to produce a new one. picoFlamingo is controlled from a laptop, using our generic SDL client + NetKitty.

It is really nice to move the 3D models with your finger, using osgviewer directly. The OpenScenegraph effort to work on OpenGL ES 2.0 platforms brings new and interesting possibilities for the forthcoming OMAP4... Stereo rendering is built-in in OSG, and the OMAP4 capability to drive two independent screens will make a lot more easier to develop real stereo applications for mobile devices.

Regarding picoFlamingo... We are quite limited on time lately, but we will try to include real 3D models in the presentation. A still missing feature. We also have to say, that picoFlamingo worked out of the box in the Zoom2. We just copy the directory with all the binary files from our BeagleBoard, into the Zoom2 SD card, and it just worked (that includes NetKitty :). So, it seems possible for picoFlamingo to also work on the OpenPandora console.

We were also thinking about how to release the sources. As usually, they need a lot of clean-up, so what we are going to do is to write a series of tutorials about OpenGL ES 2.0 programming telling you how picoFlamingo was done. The first part has already been started but it is not complete and our time is pretty limited for the next weeks. We will try to do our best.

Even when we will try to keep the tutorial general, the BeagleBoard and the OMAP Zoom2 platform will be covered specifically.

Finally, we have not yet tried !present3D, the presentation tool coming with OSG... we will do it soon!...

CU

The picoFlamingo Team

Comments

Problem with activation

Hi there, I dont know if I am writing in a proper board but I have got a problem with activation, link i receive in email is not working... (REMOVED)

Try again please

Hi,

The link in your message was definitely invalid. Something was wrong with your registration process as no new user has been added to the system.

Please try again, and use the user name and password provided by the e-mail you get after registration to login.

If the problem persists, please contact us

Many thanks